Skip to main content

Elasticsearch v2

This Integration is part of the Elasticsearch Pack.#

Supported versions

Available on Cortex XSOAR and Cortex XSIAM.

Elasticsearch_v2 integration is used to search for and analyze data in real time. Supports version 6 and later. This integration was integrated and tested with versions 6.6.2, 7.3, 8.4.1 of Elasticsearch.

Permissions#

The permissions required to use this integration depends on which operations you need to perform. The API user should have the same permissions a regular user would have in order to access the data via the UI. Following are the permissions needed for certain commands:

  • !es-eql-search/search/es-search/fetch-incidents - If the Elasticsearch security features are enabled, you must have the read index privilege for the target data stream, index, or alias.
  • !get-mapping-fields - If the Elasticsearch security features are enabled, you must have the view_index_metadata or manage index privilege for the target data stream, index, or alias.
  • !es-index - If the Elasticsearch security features are enabled, you must have the write index privilege for the target data stream, index, or alias.
  • !es-kibana-* commands - To execute Kibana commands, you must have the necessary privileges for the applicable resource. The privilege required depends on the command you are using. Kibana API endpoints are gated by feature privileges granted at one of two levels: Read (GET / list / view operations) and All (POST / PUT / PATCH / DELETE operations). For rules and cases, the privilege is scoped to the feature that owns the object — a Security-owned object requires the Security feature privilege, an Observability-owned object requires the Observability feature privilege, and a stack-owned object requires the Management / Stack Rules feature privilege.

Configure Elasticsearch v2 in Cortex#

ParameterDescriptionRequired
Server URLThe Elasticsearch server to which the integration connects. Ensure that the URL includes the correct Elasticsearch port. The default port for Elasticsearch v7 and below is 9200. Use the Server URL for on-premises deployments.False
Authorization typeSelect the authentication type and enter the appropriate credentials:
- Basic Auth: Enter Username and Password.
- Bearer Auth: Enter Username and Password.
- API Key Auth: Enter the API Key ID and API Key.
True
API key IDUse for API key authFalse
API KeyUse for API key authFalse
UsernameUse for API Key auth. Optionally you can use Username as an API key ID and Password as an API key for Basic auth.False
PasswordUse for API Key auth. Optionally you can use Username as an API key ID and Password as an API key for Basic auth.False
Trust any certificate (not secure)False
Use system proxy settingsFalse
Client typeIn some hosted ElasticSearch environments, the standard ElasticSearch client is not supported. If you encounter any related client issues, please consider using the OpenSearch client type.False
Index to fetch incidents fromCSVFalse
Query StringQuery string uses the Lucene syntax.
For more information about the Lucene syntax see here.
The query will be used when fetching incidents. Index time field will be used as a filter in the query.

The integration test button doesn't fully test the fetch incidents validity. To verify that the instance is set up correctly for fetching incidents, run the '!es-integration-health-check' command.
False
Fields to fetch (_source already included)A comma-separated list of Elasticsearch fields to retrieve in addition to the default _source fields. For example: host.hostname, host.id.False
Index time fieldThe time field used for sorting and limiting results. If using a nested field, separate field names with dot notation.False
Raw QueryRaw Query allows raw DSL queries and will override the 'Query String' Lucene syntax string.
Results will not be filtered or sorted. Use additional parameters in the raw query for these purposes.
For more information about Query DSL see here.

The integration test button doesn't fully test the fetch incidents validity. To verify that the instance is set up correctly for fetching incidents, run the '!es-integration-health-check' command.
False
Time field type3 formats supported:
Simple-Date - A plain date string. You must specify the format in which the date is stored.
For more information about time formatting, see here.
Timestamp-Second - A numeric value representing the number of seconds since the Unix epoch (00:00:00 UTC on 1 January 1970). Example: '1572164838'
* Timestamp-Milliseconds - A numeric value representing the number of milliseconds since the Unix epoch. Example: '1572164838123'
False
Map JSON fields into labelsFalse
First fetch timestamp<number> <time unit>, e.g., 12 hours, 7 daysFalse
The maximum number of results per fetchFalse
Request timeout (in seconds).False
Incident typeFalse
Fetch incidentsFalse
Space IDThe default Kibana space ID to use for es-kibana-* commands. Used to derive the Kibana base URL from the Server URL. If a space_id argument is provided to a command, it overrides this value. See Spaces for more information.False

Commands#

You can execute these commands from the CLI, as part of an automation, or in a playbook. After you successfully execute a command, a DBot message appears in the War Room with the command details.

es-search#


Queries an index.

Base Command#

es-search

Input#

Argument NameDescriptionRequired
indexThe index in which to perform a search.Required
queryThe string to query (in Lucene syntax). Possible values are: .Optional
fieldsA comma-separated list of document fields to fetch. If empty, the entire document is fetched.Optional
explainCalculates an explanation of a score for a query. For example, "value:1.6943597". Possible values are: true, false. Default is false.Optional
pageThe page number from which to start a search. Default is 0.Optional
sizeThe number of documents displayed per page. Can be an integer between "1" and "10,000". Default is 100.Optional
sort-fieldThe field by which to sort the results table. The supported result types are boolean, numeric, date, and keyword fields. Keyword fields require the doc_values parameter to be set to "true" from the Elasticsearch server. Possible values are: .Optional
sort-orderThe order by which to sort the results table. The results tables can only be sorted if a sort-field is defined. Possible values are: asc, desc. Default is asc.Optional
query_dslWill overwrite the ‘query' arguments.Optional
timestamp_range_startThe starting time of the time range.Optional
timestamp_range_endThe ending time of the time range.Optional
timestamp_fieldTimestamp field name. Default is @timestamp.Optional

Context Output#

PathTypeDescription
Elasticsearch.Search.Results._indexStringThe index to which the document belongs.
Elasticsearch.Search.Results._idStringThe ID of the document.
Elasticsearch.Search.Results._typeStringThe mapping type of the document.
Elasticsearch.Search.max_scoreNumberThe maximum relevance score of a query.
Elasticsearch.Search.QueryStringThe query performed in the search.
Elasticsearch.Search.total.valueNumberThe number of search results.
Elasticsearch.Search.Results._scoreNumberThe relevance score of the search result.
Elasticsearch.Search.IndexStringThe index in which the search was performed.
Elasticsearch.Search.ServerStringThe server on which the search was performed.
Elasticsearch.Search.timed_outBooleanWhether the search stopped due to a timeout.
Elasticsearch.Search.tookNumberThe time in milliseconds taken for the search to complete.
Elasticsearch.Search.PageNumberThe page number from which the search started.
Elasticsearch.Search.SizeNumberThe maximum number of scores that a search can return.

search#


Searches an index.

Base Command#

search

Input#

Argument NameDescriptionRequired
indexThe index in which to perform a search.Required
queryThe string to query (in Lucene syntax). Possible values are: .Optional
fieldsA comma-separated list of document fields to fetch. If empty, fetches the entire document.Optional
explainCalculates an explanation of a score for a query. For example, "value:1.6943597". Possible values are: true, false. Default is false.Optional
pageThe page number from which to start a search. Default is 0.Optional
sizeThe number of documents displayed per page. Can be an integer between "1" and "10,000". Default is 100.Optional
sort-fieldThe field by which to sort the results table. The supported result types are boolean, numeric, date, and keyword fields. Keyword fields require the doc_values parameter to be set to "true" from the Elasticsearch server. Possible values are: .Optional
sort-orderThe order by which to sort the results table. The results tables can only be sorted if a sort-field is defined. Possible values are: asc, desc. Default is asc.Optional
timestamp_fieldTimestamp field name. Default is @timestamp.Optional

Context Output#

PathTypeDescription
Elasticsearch.Search.Results._indexStringThe index to which the document belongs.
Elasticsearch.Search.Results._idStringThe ID of the document.
Elasticsearch.Search.Results._typeStringThe mapping type of the document.
Elasticsearch.Search.max_scoreNumberThe maximum relevance score of a query.
Elasticsearch.Search.QueryStringThe query performed in the search.
Elasticsearch.Search.total.valueNumberThe number of search results.
Elasticsearch.Search.Results._scoreNumberThe relevance score of the search result.
Elasticsearch.Search.IndexStringThe index in which the search was performed.
Elasticsearch.Search.ServerStringThe server on which the search was performed.
Elasticsearch.Search.timed_outBooleanWhether the search stopped due to a time out.
Elasticsearch.Search.tookNumberThe time in milliseconds taken for the search to complete.
Elasticsearch.Search.PageNumberThe page number from which the search started.
Elasticsearch.Search.SizeNumberThe maximum number of scores that a search can return.

get-mapping-fields#


Returns the schema of the index to fetch from. This commmand should be used for debugging purposes.

Base Command#

get-mapping-fields

Input#

There are no input arguments for this command.

Context Output#

There is no context output for this command.

es-eql-search#


Search using EQL query

Base Command#

es-eql-search

Input#

Argument NameDescriptionRequired
indexThe index in which to perform a search.Required
queryThe string to query (in Lucene syntax).Required
fieldsA comma-separated list of document fields to fetch. If empty, fetches the entire document.Optional
sort-tiebreakerIf two or more events share the same timestamp, Elasticsearch uses a tiebreaker field value to sort the events in ascending order.Optional
filterFilter using query DSL.Optional
event_category_fieldThe event category field. Default is event.category.Optional
sizeThe number of documents displayed per page. Can be an integer between "1" and "10,000". Default is 100.Optional
timestamp_range_startThe starting time of the time range.Optional
timestamp_range_endThe ending time of the time range.Optional
timestamp_fieldTimestamp field name. Default is @timestamp.Optional

Context Output#

PathTypeDescription
Elasticsearch.Search.Results._indexStringThe index to which the document belongs.
Elasticsearch.Search.Results._idStringThe ID of the document.
Elasticsearch.Search.Results._typeStringThe mapping type of the document.
Elasticsearch.Search.max_scoreNumberThe maximum relevance score of a query.
Elasticsearch.Search.QueryStringThe query performed in the search.
Elasticsearch.Search.total.valueNumberThe number of search results.
Elasticsearch.Search.Results._scoreNumberThe relevance score of the search result.
Elasticsearch.Search.IndexStringThe index in which the search was performed.
Elasticsearch.Search.ServerStringThe server on which the search was performed.
Elasticsearch.Search.timed_outBooleanWhether the search stopped due to a timeout.
Elasticsearch.Search.tookNumberThe time in milliseconds taken for the search to complete.
Elasticsearch.Search.PageNumberThe page number from which the search started.
Elasticsearch.Search.SizeNumberThe maximum number of scores that a search can return.

es-index#


Indexes a document into an Elasticsearch index.

Base Command#

es-index

Input#

Argument NameDescriptionRequired
index_nameThe name of the index to ingest into.Required
documentThe document object (JSON format) to be indexed. See Elasticsearch documentation for further information about indexing documents via the Elasticsearch client.Required
idThe ID of the indexed document (will be generated if empty). The document will be updated if one with a corresponding ID exists.Optional

Context Output#

PathTypeDescription
Elasticsearch.Index.idStringThe ID of the indexed document.
Elasticsearch.Index.indexStringThe name of the index which the document was ingested to.
Elasticsearch.Index.versionNumberThe version number of the indexed document.
Elasticsearch.Index.resultStringThe result of the index operation.

Command Example#

!es-index index_name=test-xsoar document="{\"name\":\"test\"}" id=1234

Context Example#

{
"Elasticsearch": {
"Index": {
"id": "1234",
"index": "test-xsoar",
"version": 1,
"result": "created"
}
}
}

Human Readable Output#

Indexed document#

IDIndex nameVersionResult
1234test-xsoar1created

es-integration-health-check#


Returns the health status of the integration. This commmand should be used for debugging purposes.

Base Command#

es-integration-health-check

Input#

There are no input arguments for this command.

Context Output#

There is no context output for this command.

es-get-indices-statistics#


Returns Elasticsearch indices statistics and information. This command is not supported for client type OpenSearch.

Base Command#

es-get-indices-statistics

Input#

Argument NameDescriptionRequired
limitThe maximum number of indices to return. Default is 50.Optional
all_resultsWhether to retrieve all the Elasticsearch indices. If true, the "limit" argument will be ignored.Optional

Context Output#

PathTypeDescription
Elasticsearch.IndexStatistics.NameStringThe name of the index.
Elasticsearch.IndexStatistics.StatusStringThe status of the index.
Elasticsearch.IndexStatistics.HealthStringThe health status of the index.
Elasticsearch.IndexStatistics.UUIDStringThe UUID of the index.
Elasticsearch.IndexStatistics.DocumentsCountNumberThe number of documents that are indexed in the index.
Elasticsearch.IndexStatistics.DocumentsDeletedNumberThe number of documents that were deleted from the index.

es-esql-search#


Search using ES|QL query (Elasticsearch 8.11 and above).

Base Command#

es-esql-search

Input#

Argument NameDescriptionRequired
queryThe ES|QL query string to execute using piped syntax (for example, FROM indexWHERE field == "value").
limitMaximum number of results to return.Optional

Context Output#

PathDescriptionType
Elasticsearch.ESQLSearchES|QL search resultunknown

Command Example#

!es-esql-search query="FROM logs-* | WHERE host.name == \"web-01\" | LIMIT 5"

Context Example#

{
"Elasticsearch": {
"ESQLSearch": [
{
"@timestamp": "2024-01-15T10:23:45.000Z",
"host.name": "web-01",
"message": "Connection established"
}
]
}
}

Human Readable Output#

Search query#

QueryTotal
FROM logs-* | WHERE host.name == "web-01" | LIMIT 51

Results#

@timestamphost.namemessage
2024-01-15T10:23:45.000Zweb-01Connection established

es-kibana-alerting-health-get#


Retrieves the health of the Kibana alerting framework.

Base Command#

es-kibana-alerting-health-get

Input#

Argument NameDescriptionRequired
space_idRefer to https://www.elastic.co/docs/deploy-manage/manage-spaces for more information.Optional

Context Output#

PathTypeDescription
Elasticsearch.Kibana.AlertingHealth.is_sufficiently_secureBooleanWhether the alerting framework is sufficiently secure.
Elasticsearch.Kibana.AlertingHealth.has_permanent_encryption_keyBooleanWhether a permanent encryption key is configured.
Elasticsearch.Kibana.AlertingHealth.alerting_framework_health.decryption_health.statusStringThe decryption health status.
Elasticsearch.Kibana.AlertingHealth.alerting_framework_health.execution_health.statusStringThe execution health status.
Elasticsearch.Kibana.AlertingHealth.alerting_framework_health.read_health.statusStringThe read health status.

Command Example#

!es-kibana-alerting-health-get

Context Example#

{
"Elasticsearch": {
"Kibana": {
"AlertingHealth": {
"is_sufficiently_secure": true,
"has_permanent_encryption_key": true,
"alerting_framework_health": {
"decryption_health": {"status": "ok"},
"execution_health": {"status": "ok"},
"read_health": {"status": "ok"}
}
}
}
}
}

Human Readable Output#

Kibana Alerting Framework Health#

Is sufficiently secureHas permanent encryption keyDecryption statusExecution statusRead status
truetrueokokok

es-kibana-rule-types-list#


Retrieves all rule types available in Kibana.

Base Command#

es-kibana-rule-types-list

Input#

Argument NameDescriptionRequired
space_idRefer to https://www.elastic.co/docs/deploy-manage/manage-spaces for more information.Optional

Context Output#

PathTypeDescription
Elasticsearch.Kibana.RuleType.idStringThe rule type ID.
Elasticsearch.Kibana.RuleType.nameStringThe rule type name.
Elasticsearch.Kibana.RuleType.categoryStringThe rule type category.
Elasticsearch.Kibana.RuleType.producerStringThe rule type producer.
Elasticsearch.Kibana.RuleType.action_groups.idStringThe action group ID.

Command Example#

!es-kibana-rule-types-list

Context Example#

{
"Elasticsearch": {
"Kibana": {
"RuleType": [
{
"id": ".index-threshold",
"name": "Index threshold",
"category": "management",
"producer": "stackAlerts",
"action_groups": [{"id": "threshold met"}, {"id": "recovered"}]
}
]
}
}
}

Human Readable Output#

Kibana Rule Types#

Rule type IDNameCategoryProducerAction Group Id
.index-thresholdIndex thresholdmanagementstackAlertsthreshold met, recovered

es-kibana-rule-list#


Retrieves information about rules.

Base Command#

es-kibana-rule-list

Input#

Argument NameDescriptionRequired
space_idRefer to https://www.elastic.co/docs/deploy-manage/manage-spaces for more information.Optional
rule_idThe identifier for the rule.Optional
searchAn Elasticsearch simple_query_string query that filters the objects in the response.Optional
default_search_operatorThe default operator to use for the simple_query_string.Optional
search_fieldsThe fields to perform the simple_query_string parsed query against.Optional
sort_fieldDetermines which field is used to sort the results.Optional
sort_orderDetermines the sort order.Optional
has_reference_idFilters the rules that have a relation with the reference objects with a specific identifier.Optional
has_reference_typeFilters the rules that have a relation with the reference objects with a specific type.Optional
fieldsThe fields to return in the attributes key of the response.Optional
filterA KQL string that you filter with an attribute from your saved object.Optional
filter_consumersList of consumers to filter.Optional
pageThe page number from which to start a search.Optional
sizeThe number of rules to return per page.Optional

Context Output#

PathTypeDescription
Elasticsearch.Kibana.Rule.idStringThe rule ID.
Elasticsearch.Kibana.Rule.enabledBooleanWhether the rule is enabled.
Elasticsearch.Kibana.Rule.nameStringThe rule name.
Elasticsearch.Kibana.Rule.rule_type_idStringThe rule type ID.
Elasticsearch.Kibana.Rule.created_atDateThe creation date of the rule.

Command Example#

!es-kibana-rule-list rule_id="1234"

Context Example#

{
"Elasticsearch": {
"Kibana": {
"Rule": {
"id": "1234",
"enabled": true,
"name": "CPU threshold alert",
"rule_type_id": ".index-threshold",
"created_at": "2024-01-10T08:00:00.000Z"
}
}
}
}

Human Readable Output#

Kibana Rules#

Rule IDEnabledNameType IDCreation date
1234trueCPU threshold alert.index-threshold2024-01-10T08:00:00.000Z

es-kibana-rule-enable#


Enable a rule.

Base Command#

es-kibana-rule-enable

Input#

Argument NameDescriptionRequired
space_idRefer to https://www.elastic.co/docs/deploy-manage/manage-spaces for more information.Optional
rule_idThe identifier for the rule.Required

Context Output#

There is no context output for this command.

Command Example#

!es-kibana-rule-enable rule_id="1234"

Context Example#

{}

Human Readable Output#

The rule 1234 has been successfully enabled.

es-kibana-rule-disable#


Disable a rule.

Base Command#

es-kibana-rule-disable

Input#

Argument NameDescriptionRequired
space_idRefer to https://www.elastic.co/docs/deploy-manage/manage-spaces for more information.Optional
rule_idThe identifier for the rule.Required

Context Output#

There is no context output for this command.

Command Example#

!es-kibana-rule-disable rule_id="1234"

Context Example#

{}

Human Readable Output#

The rule 1234 has been successfully disabled.

es-kibana-rule-update#


Update a rule.

Base Command#

es-kibana-rule-update

Input#

Argument NameDescriptionRequired
space_idRefer to https://www.elastic.co/docs/deploy-manage/manage-spaces for more information.Optional
rule_idThe identifier for the rule.Required
alert_delay_activeThe number of consecutive runs that must meet the rule conditions.Optional
artifacts_dashboards_idNot more than 10 elements.Optional
artifacts_investigation_guide_blobMaximum length is 10000.Optional
consumerThe name of the application or feature that owns the rule.Optional
enabledIndicates whether you want the rule to run on an interval basis after it is created.Optional
flapping_enabledDetermines whether the rule can enter the flapping state.Optional
flapping_look_back_windowThe minimum number of runs in which the threshold must be met. Minimum value is 2, maximum value is 20.Optional
flapping_status_change_thresholdThe minimum number of times an alert must switch states within the defined look back window time.Optional
nameThe name of the rule.Optional
notify_whenIndicates how frequently rule actions are triggered.Optional
schedule_intervalThe interval is specified in seconds, minutes, hours, or days.Optional
tagsThe tags for the rule.Optional
entry_idEntry ID for the file containing the request JSON. If provided, other parameters won't be considered.Optional

Context Output#

PathTypeDescription
Elasticsearch.Kibana.Rule.idStringThe rule ID.

Command Example#

!es-kibana-rule-update rule_id="1234" name="Updated CPU alert" schedule_interval="5m"

Context Example#

{
"Elasticsearch": {
"Kibana": {
"Rule": {
"id": "1234",
"name": "Updated CPU alert",
"enabled": true,
"rule_type_id": ".index-threshold",
"created_at": "2024-01-10T08:00:00.000Z"
}
}
}
}

Human Readable Output#

The rule 1234 has been successfully changed.

Rule IDChanged fields
1234name, schedule

es-kibana-rule-alert-mute#


Mute an alert, or mute all alerts for a rule.

Base Command#

es-kibana-rule-alert-mute

Input#

Argument NameDescriptionRequired
space_idRefer to https://www.elastic.co/docs/deploy-manage/manage-spaces for more information.Optional
rule_idThe identifier for the rule.Required
alert_idThe identifier for the alert.Optional
validate_alerts_existenceWhether to validate the existence of the alert.Optional
mute_allWhether to mute all alerts.Optional

Context Output#

There is no context output for this command.

Command Example#

!es-kibana-rule-alert-mute rule_id="1234" mute_all="true"

Context Example#

{}

Human Readable Output#

The alerts have been successfully muted.

es-kibana-rule-alert-unmute#


Unmute an alert, or unmute all alerts for a rule.

Base Command#

es-kibana-rule-alert-unmute

Input#

Argument NameDescriptionRequired
space_idRefer to https://www.elastic.co/docs/deploy-manage/manage-spaces for more information.Optional
rule_idThe identifier for the rule.Required
alert_idThe identifier for the alert.Optional
unmute_allWhether to unmute all alerts.Optional

Context Output#

There is no context output for this command.

Command Example#

!es-kibana-rule-alert-unmute rule_id="1234" unmute_all="true"

Context Example#

{}

Human Readable Output#

The alerts have been successfully unmuted.

es-kibana-detection-alert-status-set#


Set the status of one or more detection alerts.

Base Command#

es-kibana-detection-alert-status-set

Input#

Argument NameDescriptionRequired
space_idRefer to https://www.elastic.co/docs/deploy-manage/manage-spaces for more information.Optional
statusThe new status of the detection alert(s).Required
signal_idsList of alert IDs. Use field _id on alert document or kibana.alert.uuid.Optional
queryAn Elasticsearch query used to select which alerts to update, as an alternative to signal_ids.Optional
reasonThe reason for the status change.Optional
conflictsDetermines how version conflicts should be handled.Optional

Context Output#

PathTypeDescription
Elasticsearch.Kibana.SecurityAlertSetStatus.totalNumberThe total number of alerts matched by the request.
Elasticsearch.Kibana.SecurityAlertSetStatus.updatedNumberThe number of alerts that were updated.

Command Example#

!es-kibana-detection-alert-status-set status="closed" signal_ids="1234,5678"

Context Example#

{
"Elasticsearch": {
"Kibana": {
"SecurityAlertSetStatus": {
"total": 2,
"updated": 2
}
}
}
}

Human Readable Output#

Kibana Detection Alert Status Update#

TotalUpdated
22

es-kibana-case-create#


Creates a new case in Kibana.

Base Command#

es-kibana-case-create

Input#

Argument NameDescriptionRequired
space_idRefer to https://www.elastic.co/docs/deploy-manage/manage-spaces for more information.Optional
assignee_uidAn array containing users that are assigned to the case. Not more than 10 elements.Optional
categoryA word or phrase that categorizes the case. Maximum length is 50.Optional
connector_fieldsA JSON object containing the connector fields. To create a case without a connector, specify null.Optional
connector_idThe identifier for the connector. To create a case without a connector, use none.Optional
connector_nameThe name of the connector. To create a case without a connector, use none.Optional
connector_typeThe type of connector. To create a case without a connector, use none.Optional
connector_fields_issue_type_jiraThe type of issue.Optional
connector_fields_parent_jiraThe key of the parent issue, when the issue type is sub-task.Optional
connector_fields_priority_jiraThe priority of the issue.Optional
connector_fields_issue_types_resilientThe type of incident.Optional
connector_fields_severity_code_resilientThe severity code of the incident.Optional
connector_fields_category_servicenowThe category of the incident.Optional
connector_fields_impact_servicenowThe effect an incident had on business.Optional
connector_fields_severity_servicenowThe severity of the incident.Optional
connector_fields_subcategory_servicenowThe subcategory of the incident.Optional
connector_fields_urgency_servicenowThe extent to which the incident resolution can be delayed.Optional
connector_fields_dest_ip_servicenowIndicates whether cases will send a comma-separated list of destination IPs.Optional
connector_fields_malware_hash_servicenowIndicates whether cases will send a comma-separated list of malware hashes.Optional
connector_fields_malware_url_servicenowIndicates whether cases will send a comma-separated list of malware URLs.Optional
connector_fields_priority_servicenowThe priority of the issue.Optional
connector_fields_source_ip_servicenowIndicates whether cases will send a comma-separated list of source IPs.Optional
connector_fields_case_id_swimlaneThe case identifier for Swimlane connectors.Optional
custom_keyThe unique identifier for the custom field. The key value must exist in the case configuration settings.Optional
custom_typeThe custom field type. It must match the type specified in the case configuration settings.Optional
custom_valueThe custom field value (string or boolean).Optional
descriptionThe description for the case. Maximum length is 30000.Optional
ownerThe application that owns the cases: Stack Management, Observability, or Elastic Security.Required
extract_observablesWhen true, observables (e.g. IPs, hashes, URLs) are automatically extracted from case comments.Optional
sync_alertsTurns alert syncing on or off.Optional
severityThe severity of the case.Optional
tagsThe words and phrases that help categorize cases. Not more than 200 elements.Optional
titleA title for the case. Maximum length is 160.Optional
entry_idEntry ID for the file containing the full request JSON. If provided, other parameters won't be considered.Optional

Context Output#

PathTypeDescription
Elasticsearch.Kibana.Case.titleStringThe title of the case.
Elasticsearch.Kibana.Case.idStringThe case ID.
Elasticsearch.Kibana.Case.descriptionStringThe description of the case.
Elasticsearch.Kibana.Case.ownerStringThe owner of the case.
Elasticsearch.Kibana.Case.severityStringThe severity of the case.
Elasticsearch.Kibana.Case.statusStringThe status of the case.
Elasticsearch.Kibana.Case.created_atDateThe creation date of the case.
Elasticsearch.Kibana.Case.connector.typeStringThe connector type of the case.

Command Example#

!es-kibana-case-create owner="securitySolution" title="Suspicious login" description="Multiple failed logins detected" severity="medium"

Context Example#

{
"Elasticsearch": {
"Kibana": {
"Case": {
"id": "1234",
"title": "Suspicious login",
"description": "Multiple failed logins detected",
"owner": "securitySolution",
"severity": "medium",
"status": "open",
"created_at": "2024-01-15T10:00:00.000Z",
"connector": {"type": ".none"}
}
}
}
}

Human Readable Output#

Kibana Case#

TitleIDDescriptionOwnerSeverityStatusCreated atConnector type
Suspicious login1234Multiple failed logins detectedsecuritySolutionmediumopen2024-01-15T10:00:00.000Z.none

es-kibana-case-update#


Update cases in Kibana.

Base Command#

es-kibana-case-update

Input#

Argument NameDescriptionRequired
space_idRefer to https://www.elastic.co/docs/deploy-manage/manage-spaces for more information.Optional
case_idThe identifier for the case.Required
versionThe current version of the case. To determine this value, use es-kibana-case-list.Required
assignee_uidAn array containing users that are assigned to the case. Not more than 10 elements.Optional
categoryA word or phrase that categorizes the case. Maximum length is 50.Optional
close_reasonThe close reason to sync to attached alerts when closing the case.Optional
connector_fieldsA JSON object containing the connector fields. To remove a connector, specify null.Optional
connector_idThe identifier for the connector. To remove a connector, specify none.Optional
connector_nameThe name of the connector. To remove a connector, specify none.Optional
connector_typeThe type of connector. To remove a connector, specify none.Optional
connector_fields_issue_type_jiraThe type of issue.Optional
connector_fields_parent_jiraThe key of the parent issue, when the issue type is sub-task.Optional
connector_fields_priority_jiraThe priority of the issue.Optional
connector_fields_issue_types_resilientThe type of incident.Optional
connector_fields_severity_code_resilientThe severity code of the incident.Optional
connector_fields_category_servicenowThe category of the incident.Optional
connector_fields_impact_servicenowThe effect an incident had on business.Optional
connector_fields_severity_servicenowThe severity of the incident.Optional
connector_fields_subcategory_servicenowThe subcategory of the incident.Optional
connector_fields_urgency_servicenowThe extent to which the incident resolution can be delayed.Optional
connector_fields_dest_ip_servicenowIndicates whether cases will send a comma-separated list of destination IPs.Optional
connector_fields_malware_hash_servicenowIndicates whether cases will send a comma-separated list of malware hashes.Optional
connector_fields_malware_url_servicenowIndicates whether cases will send a comma-separated list of malware URLs.Optional
connector_fields_priority_servicenowThe priority of the issue.Optional
connector_fields_source_ip_servicenowIndicates whether cases will send a comma-separated list of source IPs.Optional
connector_fields_case_id_swimlaneThe case identifier for Swimlane connectors.Optional
custom_keyThe unique identifier for the custom field. The key value must exist in the case configuration settings.Optional
custom_typeThe custom field type. It must match the type specified in the case configuration settings.Optional
custom_valueThe custom field value (string or boolean).Optional
descriptionThe description for the case. Maximum length is 30000.Optional
extract_observablesWhen true, observables (e.g. IPs, hashes, URLs) are automatically extracted from case comments.Optional
sync_alertsTurns alert syncing on or off.Optional
severityThe severity of the case.Optional
statusThe status of the case.Optional
tagsThe words and phrases that help categorize cases. Not more than 200 elements.Optional
titleA title for the case. Maximum length is 160.Optional
entry_idEntry ID for the file containing the request JSON. If provided, other parameters won't be considered.Optional

Context Output#

PathTypeDescription
Elasticsearch.Kibana.Case.titleStringThe title of the case.
Elasticsearch.Kibana.Case.idStringThe case ID.
Elasticsearch.Kibana.Case.descriptionStringThe description of the case.
Elasticsearch.Kibana.Case.ownerStringThe owner of the case.
Elasticsearch.Kibana.Case.severityStringThe severity of the case.
Elasticsearch.Kibana.Case.statusStringThe status of the case.
Elasticsearch.Kibana.Case.created_atDateThe creation date of the case.
Elasticsearch.Kibana.Case.connector.typeStringThe connector type of the case.

Command Example#

!es-kibana-case-update case_id="1234" version="WzEsMV0=" title="Suspicious login - updated" severity="high"

Context Example#

{
"Elasticsearch": {
"Kibana": {
"Case": {
"id": "1234",
"title": "Suspicious login - updated",
"description": "Multiple failed logins detected",
"owner": "securitySolution",
"severity": "high",
"status": "open",
"created_at": "2024-01-15T10:00:00.000Z",
"connector": {"type": ".none"}
}
}
}
}

Human Readable Output#

Kibana Case(s) Updated#

TitleIDDescriptionOwnerSeverityStatusCreated atConnector type
Suspicious login - updated1234Multiple failed logins detectedsecuritySolutionhighopen2024-01-15T10:00:00.000Z.none

es-kibana-case-delete#


Deletes one or more cases by ID.

Base Command#

es-kibana-case-delete

Input#

Argument NameDescriptionRequired
space_idRefer to https://www.elastic.co/docs/deploy-manage/manage-spaces for more information.Optional
case_idThe cases that you want to remove. To get the case identifiers, use es-kibana-case-list.Required

Context Output#

There is no context output for this command.

Command Example#

!es-kibana-case-delete case_id="1234"

Context Example#

{}

Human Readable Output#

The cases 1234 have been successfully deleted.

es-kibana-case-list#


Retrieves the details of Kibana cases.

Base Command#

es-kibana-case-list

Input#

Argument NameDescriptionRequired
space_idRefer to https://www.elastic.co/docs/deploy-manage/manage-spaces for more information.Optional
case_idThe identifier for the case. To retrieve case IDs, use the search cases API (leave empty).Optional
assigneesFilters the returned cases by assignees. Valid values are none or unique identifiers for the user profiles.Optional
categoryFilters the returned cases by category.Optional
default_search_operatorThe default operator to use for the simple_query_string.Optional
searchAn Elasticsearch simple_query_string query that filters the objects in the response.Optional
fromReturns only cases that were created after a specific date (KQL data range or date match expression).Optional
toReturns only cases that were created before a specific date (KQL data range or date match expression).Optional
ownerA filter to limit the response to a specific set of applications.Optional
reportersFilters the returned cases by the user name of the reporter.Optional
search_fieldsThe fields to perform the simple_query_string parsed query against.Optional
severityThe severity of the case.Optional
sort_fieldDetermines which field is used to sort the results.Optional
sort_orderDetermines the sort order.Optional
statusFilters the returned cases by state.Optional
tagsFilters the returned cases by tags.Optional
pageThe page number from which to start a search.Optional
sizeThe number of items to return. Limited to 100 items.Optional

Context Output#

PathTypeDescription
Elasticsearch.Kibana.Case.titleStringThe title of the case.
Elasticsearch.Kibana.Case.idStringThe case ID.
Elasticsearch.Kibana.Case.descriptionStringThe description of the case.
Elasticsearch.Kibana.Case.ownerStringThe owner of the case.
Elasticsearch.Kibana.Case.severityStringThe severity of the case.
Elasticsearch.Kibana.Case.statusStringThe status of the case.
Elasticsearch.Kibana.Case.created_atDateThe creation date of the case.
Elasticsearch.Kibana.Case.connector.typeStringThe connector type of the case.

Command Example#

!es-kibana-case-list

Context Example#

{
"Elasticsearch": {
"Kibana": {
"Case": [
{
"id": "1234",
"title": "Suspicious login",
"description": "Multiple failed logins detected",
"owner": "securitySolution",
"severity": "medium",
"status": "open",
"created_at": "2024-01-15T10:00:00.000Z",
"connector": {"type": ".none"}
}
]
}
}
}

Human Readable Output#

Kibana Cases#

TitleIDDescriptionOwnerSeverityStatusCreated atConnector type
Suspicious login1234Multiple failed logins detectedsecuritySolutionmediumopen2024-01-15T10:00:00.000Z.none

es-kibana-case-alerts-list#


Retrieves all alerts for a case.

Base Command#

es-kibana-case-alerts-list

Input#

Argument NameDescriptionRequired
space_idRefer to https://www.elastic.co/docs/deploy-manage/manage-spaces for more information.Optional
case_idThe identifier for the case. To retrieve case IDs, use es-kibana-case-list.Required
limitLimit on the number of keys to return.Optional
offsetStarting record index to begin retrieving records from.Optional

Context Output#

PathTypeDescription
Elasticsearch.Kibana.Case.Alert.idStringThe alert ID.
Elasticsearch.Kibana.Case.Alert.indexStringThe alert index.
Elasticsearch.Kibana.Case.Alert.attached_atDateThe date the alert was attached to the case.

Command Example#

!es-kibana-case-alerts-list case_id="1234"

Context Example#

{
"Elasticsearch": {
"Kibana": {
"Case": {
"1234": {
"Alert": [
{
"id": "5678",
"index": ".alerts-security.alerts-default",
"attached_at": "2024-01-15T11:00:00.000Z"
}
]
}
}
}
}
}

Human Readable Output#

Alerts for Case 1234#

Case idAttached atAlert idIndex
12342024-01-15T11:00:00.000Z5678.alerts-security.alerts-default

es-kibana-case-comment-add#


Add a case comment or alert.

Base Command#

es-kibana-case-comment-add

Input#

Argument NameDescriptionRequired
space_idRefer to https://www.elastic.co/docs/deploy-manage/manage-spaces for more information.Optional
case_idThe identifier for the case. To retrieve case IDs, use es-kibana-case-list.Required
alert_idThe alert identifiers. Required only when type is alert.Optional
indexThe alert indices. Required only when type is alert.Optional
ownerThe application that owns the cases: Stack Management, Observability, or Elastic Security.Required
rule_idThe rule identifier.Optional
rule_nameThe rule name.Optional
typeThe type of comment.Required
commentThe new comment. Required only when type is user. Maximum length is 30000.Optional

Context Output#

PathTypeDescription
Elasticsearch.Kibana.Case.idStringThe case ID.
Elasticsearch.Kibana.Case.comments.commentStringThe comment text.
Elasticsearch.Kibana.Case.comments.created_by.usernameStringThe user who created the comment.

Command Example#

!es-kibana-case-comment-add case_id="1234" type="user" owner="securitySolution" comment="Investigated and confirmed malicious activity."

Context Example#

{
"Elasticsearch": {
"Kibana": {
"Case": {
"id": "1234",
"comments": [
{
"comment": "Investigated and confirmed malicious activity.",
"created_by": {"username": "analyst"}
}
]
}
}
}
}

Human Readable Output#

Kibana Case Comment Added#

Case idCommentCreated by
1234Investigated and confirmed malicious activity.analyst

es-kibana-case-comment-update#


Update a case comment or alert.

Base Command#

es-kibana-case-comment-update

Input#

Argument NameDescriptionRequired
space_idRefer to https://www.elastic.co/docs/deploy-manage/manage-spaces for more information.Optional
case_idThe identifier for the case. To retrieve case IDs, use es-kibana-case-list.Required
comment_idThe identifier for the comment.Optional
commentThe new comment. Required only when type is user. Maximum length is 30000.Optional
alert_idThe alert identifiers. Required only when type is alert.Optional
indexThe alert indices. Required only when type is alert.Optional
ownerThe application that owns the cases: Stack Management, Observability, or Elastic Security.Required
rule_idThe rule identifier.Optional
rule_nameThe rule name.Optional
typeThe type of comment.Required
versionThe current comment version. To retrieve version values, use the get comments API.Optional

Context Output#

PathTypeDescription
Elasticsearch.Kibana.Case.idStringThe case ID.
Elasticsearch.Kibana.Case.comments.commentStringThe comment text.
Elasticsearch.Kibana.Case.comments.updated_by.usernameStringThe user who updated the comment.
Elasticsearch.Kibana.Case.comments.updated_atDateThe date the comment was updated.

Command Example#

!es-kibana-case-comment-update case_id="1234" comment_id="5678" type="user" owner="securitySolution" comment="Updated: confirmed false positive." version="WzEsMV0="

Context Example#

{
"Elasticsearch": {
"Kibana": {
"Case": {
"id": "1234",
"comments": [
{
"id": "5678",
"comment": "Updated: confirmed false positive.",
"updated_by": {"username": "analyst"},
"updated_at": "2024-01-15T12:00:00.000Z"
}
]
}
}
}
}

Human Readable Output#

Kibana Case Comment Updated#

Case idCommentUpdated byUpdated at
1234Updated: confirmed false positive.analyst2024-01-15T12:00:00.000Z

es-kibana-case-comment-delete#


Deletes all comments and alerts from a case.

Base Command#

es-kibana-case-comment-delete

Input#

Argument NameDescriptionRequired
space_idRefer to https://www.elastic.co/docs/deploy-manage/manage-spaces for more information.Optional
case_idThe identifier for the case. To retrieve case IDs, use es-kibana-case-list.Required

Context Output#

There is no context output for this command.

Command Example#

!es-kibana-case-comment-delete case_id="1234"

Context Example#

{}

Human Readable Output#

The comments and alerts for the case 1234 have been successfully deleted.

es-kibana-case-file-attach#


Attach a file to a case.

Base Command#

es-kibana-case-file-attach

Input#

Argument NameDescriptionRequired
space_idRefer to https://www.elastic.co/docs/deploy-manage/manage-spaces for more information.Optional
case_idThe identifier for the case. To retrieve case IDs, use es-kibana-case-list.Required
entry_idEntry ID for the file that needs to be attached.Required
file_nameThe desired name of the file being attached to the case (without file extension).Optional

Context Output#

PathTypeDescription
Elasticsearch.Kibana.Case.idStringThe case ID.
Elasticsearch.Kibana.Case.comments.updated_by.usernameStringThe user who attached the file.

Command Example#

!es-kibana-case-file-attach case_id="1234" entry_id="1@1"

Context Example#

{
"Elasticsearch": {
"Kibana": {
"Case": {
"id": "1234",
"comments": [
{
"updated_by": {"username": "analyst"}
}
]
}
}
}
}

Human Readable Output#

File successfully attached to case 1234.

es-kibana-endpoint-exception-list-item-create#


Create an Elastic Endpoint exception list item, and associate it with the Elastic Endpoint exception list.

Base Command#

es-kibana-endpoint-exception-list-item-create

Input#

Argument NameDescriptionRequired
space_idRefer to https://www.elastic.co/docs/deploy-manage/manage-spaces for more information.Optional
descriptionDescribes the exception list.Optional
entries_fieldA string that does not contain only whitespace characters.Optional
entries_list_idValue list's identifier.Optional
entries_list_typeSpecifies the Elasticsearch data type of excludes the list container holds.Optional
entries_operatorThe exception item entry operator.Optional
entries_typeThe exception item entry type.Optional
item_idHuman readable string identifier, e.g. trusted-linux-processes.Optional
metaAdditional properties are allowed (JSON object).Optional
nameException list name. Minimum length is 1.Optional
os_typesUse this field to specify the operating system.Optional
tagsString array containing words and phrases to help categorize exception items.Optional
entry_idEntry ID for the file containing the full request JSON. If provided, other parameters won't be considered.Optional

Context Output#

PathTypeDescription
Elasticsearch.Kibana.EndpointExceptionListItem.idStringThe exception list item ID.
Elasticsearch.Kibana.EndpointExceptionListItem.item_idStringThe exception list item human-readable ID.
Elasticsearch.Kibana.EndpointExceptionListItem.list_idStringThe exception list ID.
Elasticsearch.Kibana.EndpointExceptionListItem.nameStringThe exception list item name.
Elasticsearch.Kibana.EndpointExceptionListItem.descriptionStringThe exception list item description.
Elasticsearch.Kibana.EndpointExceptionListItem.created_atDateThe creation date of the exception list item.

Command Example#

!es-kibana-endpoint-exception-list-item-create name="Trusted process" description="Allow known safe process" entries_field="process.name" entries_type="match" entries_operator="included" entries_value="safe_process.exe" os_types="windows"

Context Example#

{
"Elasticsearch": {
"Kibana": {
"EndpointExceptionListItem": {
"id": "1234",
"item_id": "trusted-process-1",
"list_id": "endpoint_list",
"name": "Trusted process",
"description": "Allow known safe process",
"created_at": "2024-01-15T10:00:00.000Z"
}
}
}
}

Human Readable Output#

Kibana Endpoint Exception List Item#

IDItem IDList IDNameDescriptionCreation date
1234trusted-process-1endpoint_listTrusted processAllow known safe process2024-01-15T10:00:00.000Z

es-kibana-endpoint-exception-list-item-update#


Update an Elastic Endpoint exception list item.

Base Command#

es-kibana-endpoint-exception-list-item-update

Input#

Argument NameDescriptionRequired
space_idRefer to https://www.elastic.co/docs/deploy-manage/manage-spaces for more information.Optional
exception_list_item_idException's identifier.Optional
item_idHuman readable string identifier, e.g. trusted-linux-processes.Optional
_versionThe version id, normally returned by the API when the item is retrieved.Optional
descriptionDescribes the exception list.Optional
entries_fieldA string that does not contain only whitespace characters.Optional
entries_list_idValue list's identifier.Optional
entries_list_typeSpecifies the Elasticsearch data type of excludes the list container holds.Optional
entries_operatorThe exception item entry operator.Optional
entries_typeThe exception item entry type.Optional
entries_valueA string that does not contain only whitespace characters.Optional
metaAdditional properties are allowed (JSON object).Optional
nameException list name. Minimum length is 1.Optional
os_typesUse this field to specify the operating system.Optional
tagsString array containing words and phrases to help categorize exception items.Optional
entry_idEntry ID for the file containing the full request JSON. If provided, other parameters won't be considered.Optional

Context Output#

PathTypeDescription
Elasticsearch.Kibana.EndpointExceptionListItem.idStringThe exception list item ID.
Elasticsearch.Kibana.EndpointExceptionListItem.item_idStringThe exception list item human-readable ID.
Elasticsearch.Kibana.EndpointExceptionListItem.list_idStringThe exception list ID.
Elasticsearch.Kibana.EndpointExceptionListItem.nameStringThe exception list item name.
Elasticsearch.Kibana.EndpointExceptionListItem.descriptionStringThe exception list item description.
Elasticsearch.Kibana.EndpointExceptionListItem.created_atDateThe creation date of the exception list item.

Command Example#

!es-kibana-endpoint-exception-list-item-update item_id="trusted-process-1" name="Trusted process updated" description="Updated description" entries_field="process.name" entries_type="match" entries_operator="included" entries_value="safe_process.exe"

Context Example#

{
"Elasticsearch": {
"Kibana": {
"EndpointExceptionListItem": {
"id": "1234",
"item_id": "trusted-process-1",
"list_id": "endpoint_list",
"name": "Trusted process updated",
"description": "Updated description",
"created_at": "2024-01-15T10:00:00.000Z"
}
}
}
}

Human Readable Output#

Kibana Endpoint Exception List Item#

IDItem IDList IDNameDescriptionCreation date
1234trusted-process-1endpoint_listTrusted process updatedUpdated description2024-01-15T10:00:00.000Z

es-kibana-endpoint-exception-list-item-delete#


Delete an Elastic Endpoint exception list item.

Base Command#

es-kibana-endpoint-exception-list-item-delete

Input#

Argument NameDescriptionRequired
space_idRefer to https://www.elastic.co/docs/deploy-manage/manage-spaces for more information.Optional
item_idEither id or item_id must be specified.Required

Context Output#

There is no context output for this command.

Command Example#

!es-kibana-endpoint-exception-list-item-delete item_id="trusted-process-1"

Context Example#

{}

Human Readable Output#

The item trusted-process-1 has been successfully deleted.

es-kibana-endpoint-exception-list-item-list#


Retrieves Elastic Endpoint exception list items.

Base Command#

es-kibana-endpoint-exception-list-item-list

Input#

Argument NameDescriptionRequired
space_idRefer to https://www.elastic.co/docs/deploy-manage/manage-spaces for more information.Optional
filterFilters the returned results according to the value of the specified field, using the <field name>:<field value> syntax.Optional
item_idEither id or item_id must be specified.Optional
sort_fieldDetermines which field is used to sort the results.Optional
sort_orderDetermines the sort order.Optional
pageThe page number to return. Minimum value is 0.Optional
sizeThe number of exception list items to return per page. Minimum value is 0.Optional

Context Output#

PathTypeDescription
Elasticsearch.Kibana.EndpointExceptionListItem.idStringThe exception list item ID.
Elasticsearch.Kibana.EndpointExceptionListItem.item_idStringThe exception list item human-readable ID.
Elasticsearch.Kibana.EndpointExceptionListItem.list_idStringThe exception list ID.
Elasticsearch.Kibana.EndpointExceptionListItem.nameStringThe exception list item name.
Elasticsearch.Kibana.EndpointExceptionListItem.descriptionStringThe exception list item description.
Elasticsearch.Kibana.EndpointExceptionListItem.created_atDateThe creation date of the exception list item.

Command Example#

!es-kibana-endpoint-exception-list-item-list

Context Example#

{
"Elasticsearch": {
"Kibana": {
"EndpointExceptionListItem": [
{
"id": "1234",
"item_id": "trusted-process-1",
"list_id": "endpoint_list",
"name": "Trusted process",
"description": "Allow known safe process",
"created_at": "2024-01-15T10:00:00.000Z"
}
]
}
}
}

Human Readable Output#

Kibana Endpoint Exception List Items#

IDItem IDList IDNameDescriptionCreation date
1234trusted-process-1endpoint_listTrusted processAllow known safe process2024-01-15T10:00:00.000Z

es-kibana-exception-list-list#


Get a list of all exception list containers.

Base Command#

es-kibana-exception-list-list

Input#

Argument NameDescriptionRequired
space_idRefer to https://www.elastic.co/docs/deploy-manage/manage-spaces for more information.Optional
exception_list_idException list's identifier. Either id or list_id must be specified.Optional
list_idHuman readable exception list string identifier. Either id or list_id must be specified.Optional
filterFilters the returned results according to the value of the specified field.Optional
namespace_typeDetermines whether the returned containers are Kibana associated with a Kibana space or available in all spaces.Optional
sort_fieldDetermines which field is used to sort the results.Optional
sort_orderDetermines the sort order.Optional
pageThe page number to return. Minimum value is 1.Optional
sizeThe number of exception lists to return per page. Minimum value is 1.Optional

Context Output#

PathTypeDescription
Elasticsearch.Kibana.ExceptionList.idStringThe exception list ID.
Elasticsearch.Kibana.ExceptionList.list_idStringThe human-readable exception list ID.
Elasticsearch.Kibana.ExceptionList.nameStringThe exception list name.
Elasticsearch.Kibana.ExceptionList.descriptionStringThe exception list description.
Elasticsearch.Kibana.ExceptionList.created_atDateThe creation date of the exception list.

Command Example#

!es-kibana-exception-list-list

Context Example#

{
"Elasticsearch": {
"Kibana": {
"ExceptionList": [
{
"id": "1234",
"list_id": "my-exception-list",
"name": "My Exception List",
"description": "Exceptions for trusted processes",
"created_at": "2024-01-15T10:00:00.000Z"
}
]
}
}
}

Human Readable Output#

Kibana Exception Lists#

Exception list IDList IDNameDescriptionCreation date
1234my-exception-listMy Exception ListExceptions for trusted processes2024-01-15T10:00:00.000Z

es-kibana-exception-list-create#


Create an exception list.

Base Command#

es-kibana-exception-list-create

Input#

Argument NameDescriptionRequired
space_idRefer to https://www.elastic.co/docs/deploy-manage/manage-spaces for more information.Optional
descriptionDescribes the exception list.Optional
list_idThe exception list's human-readable string identifier.Optional
metaPlaceholder for metadata about the list container (JSON object).Optional
nameThe name of the exception list.Optional
namespace_typeDetermines whether the returned containers are Kibana associated with a Kibana space or available in all spaces.Optional
os_typesUse this field to specify the operating system. Only enter one value.Optional
tagsString array containing words and phrases to help categorize exception containers.Optional
typeThe type of exception list to be created.Required
versionThe document version automatically increased on updates.Optional
entry_idEntry ID for the file containing the request JSON. If provided, other parameters won't be considered.Optional

Context Output#

PathTypeDescription
Elasticsearch.Kibana.ExceptionList.idStringThe exception list ID.
Elasticsearch.Kibana.ExceptionList.list_idStringThe human-readable exception list ID.
Elasticsearch.Kibana.ExceptionList.nameStringThe exception list name.
Elasticsearch.Kibana.ExceptionList.descriptionStringThe exception list description.
Elasticsearch.Kibana.ExceptionList.created_atDateThe creation date of the exception list.

Command Example#

!es-kibana-exception-list-create type="detection" name="My Exception List" description="Exceptions for trusted processes" list_id="my-exception-list"

Context Example#

{
"Elasticsearch": {
"Kibana": {
"ExceptionList": {
"id": "1234",
"list_id": "my-exception-list",
"name": "My Exception List",
"description": "Exceptions for trusted processes",
"created_at": "2024-01-15T10:00:00.000Z"
}
}
}
}

Human Readable Output#

Kibana Exception List#

Exception list IDList IDNameDescriptionCreation date
1234my-exception-listMy Exception ListExceptions for trusted processes2024-01-15T10:00:00.000Z

es-kibana-exception-list-update#


Updates an existing exception list.

Base Command#

es-kibana-exception-list-update

Input#

Argument NameDescriptionRequired
space_idRefer to https://www.elastic.co/docs/deploy-manage/manage-spaces for more information.Optional
_versionThe version id, normally returned by the API when the item was retrieved.Optional
descriptionDescribes the exception list.Required
exception_list_idException list's identifier.Optional
list_idThe exception list's human-readable string identifier.Optional
metaPlaceholder for metadata about the list container (JSON object).Optional
nameThe name of the exception list.Required
namespace_typeDetermines whether the returned containers are Kibana associated with a Kibana space or available in all spaces.Optional
os_typesUse this field to specify the operating system. Only enter one value.Optional
tagsString array containing words and phrases to help categorize exception containers.Optional
typeThe type of exception list to be created.Required
versionThe document version automatically increased on updates.Optional

Context Output#

PathTypeDescription
Elasticsearch.Kibana.ExceptionList.idStringThe exception list ID.
Elasticsearch.Kibana.ExceptionList.list_idStringThe human-readable exception list ID.
Elasticsearch.Kibana.ExceptionList.nameStringThe exception list name.
Elasticsearch.Kibana.ExceptionList.descriptionStringThe exception list description.
Elasticsearch.Kibana.ExceptionList.created_atDateThe creation date of the exception list.

Command Example#

!es-kibana-exception-list-update exception_list_id="1234" name="My Exception List Updated" description="Updated description" type="detection"

Context Example#

{
"Elasticsearch": {
"Kibana": {
"ExceptionList": {
"id": "1234",
"list_id": "my-exception-list",
"name": "My Exception List Updated",
"description": "Updated description",
"created_at": "2024-01-15T10:00:00.000Z"
}
}
}
}

Human Readable Output#

Kibana Exception List#

Exception list IDList IDNameDescriptionCreation date
1234my-exception-listMy Exception List UpdatedUpdated description2024-01-15T10:00:00.000Z

es-kibana-exception-list-delete#


Delete an exception list using the id or list_id field.

Base Command#

es-kibana-exception-list-delete

Input#

Argument NameDescriptionRequired
space_idRefer to https://www.elastic.co/docs/deploy-manage/manage-spaces for more information.Optional
exception_list_idException list's identifier. Either id or list_id must be specified.Optional
list_idHuman readable exception list string identifier. Either id or list_id must be specified.Optional
namespace_typeDetermines whether the returned containers are Kibana associated with a Kibana space or available in all spaces.Optional

Context Output#

There is no context output for this command.

Command Example#

!es-kibana-exception-list-delete list_id="my-exception-list"

Context Example#

{}

Human Readable Output#

The exception list my-exception-list has been successfully deleted.

es-kibana-exception-list-item-list#


Get a list of all exception list items in the specified list.

Base Command#

es-kibana-exception-list-item-list

Input#

Argument NameDescriptionRequired
space_idRefer to https://www.elastic.co/docs/deploy-manage/manage-spaces for more information.Optional
exception_list_item_idException list item's identifier. Either id or item_id must be specified.Optional
item_idHuman readable exception item string identifier. Either id or item_id must be specified.Optional
exception_list_idThe list_ids of the items to fetch.Optional
filterFilters the returned results according to the value of the specified field, using the <field name>:<field value> syntax.Optional
namespace_typeDetermines whether the returned containers are Kibana associated with a Kibana space or available in all spaces.Optional
searchFree-text search term applied to exception list item fields.Optional
sort_fieldDetermines which field is used to sort the results.Optional
sort_orderDetermines the sort order.Optional
pageThe page number to return. Minimum value is 0.Optional
sizeThe number of exception list items to return per page. Minimum value is 0.Optional

Context Output#

PathTypeDescription
Elasticsearch.Kibana.ExceptionListItem.idStringThe exception list item ID.
Elasticsearch.Kibana.ExceptionListItem.item_idStringThe exception list item human-readable ID.
Elasticsearch.Kibana.ExceptionListItem.list_idStringThe exception list ID.
Elasticsearch.Kibana.ExceptionListItem.nameStringThe exception list item name.
Elasticsearch.Kibana.ExceptionListItem.descriptionStringThe exception list item description.
Elasticsearch.Kibana.ExceptionListItem.created_atDateThe creation date of the exception list item.

Command Example#

!es-kibana-exception-list-item-list exception_list_id="my-exception-list"

Context Example#

{
"Elasticsearch": {
"Kibana": {
"ExceptionListItem": [
{
"id": "1234",
"item_id": "my-item-1",
"list_id": "my-exception-list",
"name": "Trusted IP",
"description": "Known safe IP address",
"created_at": "2024-01-15T10:00:00.000Z"
}
]
}
}
}

Human Readable Output#

Kibana Exception List Items#

IDItem IDList IDNameDescriptionCreation date
1234my-item-1my-exception-listTrusted IPKnown safe IP address2024-01-15T10:00:00.000Z

es-kibana-exception-list-item-create#


Create an exception item and associate it with the specified exception list.

Base Command#

es-kibana-exception-list-item-create

Input#

Argument NameDescriptionRequired
space_idRefer to https://www.elastic.co/docs/deploy-manage/manage-spaces for more information.Optional
commentA string that does not contain only whitespace characters.Optional
descriptionDescribes the exception list.Optional
expire_timeThe exception item's expiration date, in ISO format.Optional
item_idHuman readable string identifier, e.g. trusted-linux-processes.Optional
metaAdditional properties are allowed (JSON object).Optional
nameException list name.Optional
namespace_typeDetermines whether the returned containers are Kibana associated with a Kibana space or available in all spaces.Optional
typeThe type of exception list to be created.Optional
entries_fieldA string that does not contain only whitespace characters.Optional
entries_operatorThe exception item entry operator.Optional
entries_typeThe exception item entry type.Optional
entries_valueThe exception item entry value.Optional
entries_list_idValue list's identifier.Optional
entries_list_typeSpecifies the Elasticsearch data type of excludes the list container holds.Optional
list_idThe exception list's human-readable string identifier.Optional
os_typesUse this field to specify the operating system. Only enter one value.Optional
tagsString array containing words and phrases to help categorize exception containers.Optional
entry_idEntry ID for the file containing the request JSON. If provided, other parameters won't be considered.Optional

Context Output#

PathTypeDescription
Elasticsearch.Kibana.ExceptionListItem.idStringThe exception list item ID.
Elasticsearch.Kibana.ExceptionListItem.item_idStringThe exception list item human-readable ID.
Elasticsearch.Kibana.ExceptionListItem.list_idStringThe exception list ID.
Elasticsearch.Kibana.ExceptionListItem.nameStringThe exception list item name.
Elasticsearch.Kibana.ExceptionListItem.descriptionStringThe exception list item description.
Elasticsearch.Kibana.ExceptionListItem.created_atDateThe creation date of the exception list item.

Command Example#

!es-kibana-exception-list-item-create list_id="my-exception-list" name="Trusted IP" description="Known safe IP address" entries_field="source.ip" entries_type="match" entries_operator="included" entries_value="192.168.1.1"

Context Example#

{
"Elasticsearch": {
"Kibana": {
"ExceptionListItem": {
"id": "1234",
"item_id": "my-item-1",
"list_id": "my-exception-list",
"name": "Trusted IP",
"description": "Known safe IP address",
"created_at": "2024-01-15T10:00:00.000Z"
}
}
}
}

Human Readable Output#

Kibana Exception List Item#

IDItem IDList IDNameDescriptionCreation date
1234my-item-1my-exception-listTrusted IPKnown safe IP address2024-01-15T10:00:00.000Z

es-kibana-exception-item-list-update#


Updates an existing exception list item.

Base Command#

es-kibana-exception-item-list-update

Input#

Argument NameDescriptionRequired
space_idRefer to https://www.elastic.co/docs/deploy-manage/manage-spaces for more information.Optional
_versionThe version ID, normally returned by the API when the item is retrieved.Optional
commentA string that does not contain only whitespace characters.Optional
comment_idA string that does not contain only whitespace characters.Optional
descriptionDescribes the exception list.Optional
expire_timeThe exception item's expiration date, in ISO format.Optional
exception_list_item_idException's identifier.Optional
item_idHuman readable string identifier, e.g. trusted-linux-processes.Optional
metaAdditional properties are allowed (JSON object).Optional
nameException list name.Optional
namespace_typeDetermines whether the returned containers are Kibana associated with a Kibana space or available in all spaces.Optional
typeThe type of exception list to be created.Optional
entries_fieldA string that does not contain only whitespace characters.Optional
entries_operatorThe exception item entry operator.Optional
entries_typeThe exception item entry type.Optional
entries_valueThe exception item entry value.Optional
entries_list_idValue list's identifier.Optional
entries_list_typeSpecifies the Elasticsearch data type of excludes the list container holds.Optional
list_idThe exception list's human-readable string identifier.Optional
os_typesUse this field to specify the operating system. Only enter one value.Optional
tagsString array containing words and phrases to help categorize exception containers.Optional
entry_idEntry ID for the file containing the request JSON. If provided, other parameters won't be considered.Optional

Context Output#

PathTypeDescription
Elasticsearch.Kibana.ExceptionListItem.idStringThe exception list item ID.
Elasticsearch.Kibana.ExceptionListItem.item_idStringThe exception list item human-readable ID.
Elasticsearch.Kibana.ExceptionListItem.list_idStringThe exception list ID.
Elasticsearch.Kibana.ExceptionListItem.nameStringThe exception list item name.
Elasticsearch.Kibana.ExceptionListItem.descriptionStringThe exception list item description.
Elasticsearch.Kibana.ExceptionListItem.updated_atDateThe update date of the exception list item.

Command Example#

!es-kibana-exception-item-list-update item_id="my-item-1" name="Trusted IP updated" description="Updated safe IP" entries_field="source.ip" entries_type="match" entries_operator="included" entries_value="192.168.1.1"

Context Example#

{
"Elasticsearch": {
"Kibana": {
"ExceptionListItem": {
"id": "1234",
"item_id": "my-item-1",
"list_id": "my-exception-list",
"name": "Trusted IP updated",
"description": "Updated safe IP",
"updated_at": "2024-01-15T12:00:00.000Z"
}
}
}
}

Human Readable Output#

Kibana Exception List Item Updated#

Exception list item IDItem IdList IDNameDescriptionUpdate date
1234my-item-1my-exception-listTrusted IP updatedUpdated safe IP2024-01-15T12:00:00.000Z

es-kibana-exception-list-item-delete#


Deletes an exception list item.

Base Command#

es-kibana-exception-list-item-delete

Input#

Argument NameDescriptionRequired
space_idRefer to https://www.elastic.co/docs/deploy-manage/manage-spaces for more information.Optional
exception_list_item_idException list item's identifier. Either id or item_id must be specified.Optional
item_idHuman readable exception item string identifier. Either id or item_id must be specified.Optional
namespace_typeDetermines whether the returned containers are Kibana associated with a Kibana space or available in all spaces.Optional

Context Output#

There is no context output for this command.

Command Example#

!es-kibana-exception-list-item-delete item_id="my-item-1"

Context Example#

{}

Human Readable Output#

The exception list item my-item-1 has been successfully deleted.

es-kibana-value-lists-list#


Retrieves details of a value list (the list container).

Base Command#

es-kibana-value-lists-list

Input#

Argument NameDescriptionRequired
space_idRefer to https://www.elastic.co/docs/deploy-manage/manage-spaces for more information.Optional
value_list_idValue list identifier (id) returned when the list was created.Optional
filterFilters the returned results according to the value of the specified field, using the <field name>:<field value> syntax.Optional
cursorReturns the lists that come after the last lists returned in the previous call.Optional
sort_fieldDetermines which field is used to sort the results.Optional
sort_orderDetermines the sort order.Optional
pageThe page number to return.Optional
sizeThe number of value lists to return per page.Optional

Context Output#

PathTypeDescription
Elasticsearch.Kibana.ValueList.idStringThe value list ID.
Elasticsearch.Kibana.ValueList.nameStringThe value list name.
Elasticsearch.Kibana.ValueList.descriptionStringThe value list description.
Elasticsearch.Kibana.ValueList.created_atDateThe creation date of the value list.

Command Example#

!es-kibana-value-lists-list

Context Example#

{
"Elasticsearch": {
"Kibana": {
"ValueList": [
{
"id": "1234",
"name": "trusted-ips",
"description": "List of trusted IP addresses",
"created_at": "2024-01-15T10:00:00.000Z"
}
]
}
}
}

Human Readable Output#

Kibana Value Lists#

Value list IDNameDescriptionCreation date
1234trusted-ipsList of trusted IP addresses2024-01-15T10:00:00.000Z

es-kibana-value-list-item-get#


Retrieves value list items.

Base Command#

es-kibana-value-list-item-get

Input#

Argument NameDescriptionRequired
space_idRefer to https://www.elastic.co/docs/deploy-manage/manage-spaces for more information.Optional
value_list_item_idValue list item identifier. Required if list_id and value are not specified.Optional
value_list_idParent value list's id to page through items for.Optional
valueThe value used to evaluate exceptions. Required if id is not specified.Optional
filterFilters the returned results according to the value of the specified field, using the <field name>:<field value> syntax.Optional
cursorOpaque cursor returned in a previous response; pass it to continue listing from the next page.Optional
sort_fieldDetermines which field is used to sort the results.Optional
sort_orderDetermines the sort order.Optional
pageThe page number to return.Optional
sizeThe number of list items to return per page.Optional

Context Output#

PathTypeDescription
Elasticsearch.Kibana.ValueListItem.idStringThe value list item ID.
Elasticsearch.Kibana.ValueListItem.list_idStringThe value list ID.
Elasticsearch.Kibana.ValueListItem.nameStringThe value list item name.
Elasticsearch.Kibana.ValueListItem.descriptionStringThe value list item description.
Elasticsearch.Kibana.ValueListItem.created_atDateThe creation date of the value list item.

Command Example#

!es-kibana-value-list-item-get value_list_id="1234"

Context Example#

{
"Elasticsearch": {
"Kibana": {
"ValueListItem": [
{
"id": "5678",
"list_id": "1234",
"value": "192.168.1.1",
"created_at": "2024-01-15T10:00:00.000Z"
}
]
}
}
}

Human Readable Output#

Kibana Value List Items#

Value list item IDList IDValueCreation date
56781234192.168.1.12024-01-15T10:00:00.000Z

es-kibana-value-list-item-create#


Adds a new item to a value list.

Base Command#

es-kibana-value-list-item-create

Input#

Argument NameDescriptionRequired
space_idRefer to https://www.elastic.co/docs/deploy-manage/manage-spaces for more information.Optional
value_list_idValue list's identifier.Required
metaPlaceholder for metadata about the value list item (JSON object). Example {"source":"threatfeed","priority":3,"active":true}.Optional
refreshDetermines when changes made by the request are made visible to search.Optional
valueThe value used to evaluate exceptions.Required

Context Output#

PathTypeDescription
Elasticsearch.Kibana.ValueListItem.idStringThe value list item ID.
Elasticsearch.Kibana.ValueListItem.list_idStringThe value list ID.
Elasticsearch.Kibana.ValueListItem.nameStringThe value list item name.
Elasticsearch.Kibana.ValueListItem.descriptionStringThe value list item description.
Elasticsearch.Kibana.ValueListItem.created_atDateThe creation date of the value list item.

Command Example#

!es-kibana-value-list-item-create value_list_id="1234" value="10.0.0.1"

Context Example#

{
"Elasticsearch": {
"Kibana": {
"ValueListItem": {
"id": "5678",
"list_id": "1234",
"value": "10.0.0.1",
"created_at": "2024-01-15T10:00:00.000Z"
}
}
}
}

Human Readable Output#

Kibana Value List Item#

Value list item IDList IDValueCreation date
5678123410.0.0.12024-01-15T10:00:00.000Z

es-kibana-value-list-item-update#


Updates an existing value list item.

Base Command#

es-kibana-value-list-item-update

Input#

Argument NameDescriptionRequired
space_idRefer to https://www.elastic.co/docs/deploy-manage/manage-spaces for more information.Optional
_versionThe version id, normally returned by the API when the document is retrieved.Optional
value_list_item_idValue list item identifier.Required
metaPlaceholder for metadata about the value list item (JSON object). Example {"source":"threatfeed","priority":3,"active":true}.Optional
valueThe value used to evaluate exceptions.Required

Context Output#

PathTypeDescription
Elasticsearch.Kibana.ValueListItem.idStringThe value list item ID.
Elasticsearch.Kibana.ValueListItem.list_idStringThe value list ID.
Elasticsearch.Kibana.ValueListItem.nameStringThe value list item name.
Elasticsearch.Kibana.ValueListItem.descriptionStringThe value list item description.
Elasticsearch.Kibana.ValueListItem.created_atDateThe creation date of the value list item.

Command Example#

!es-kibana-value-list-item-update value_list_item_id="5678" value="10.0.0.2"

Context Example#

{
"Elasticsearch": {
"Kibana": {
"ValueListItem": {
"id": "5678",
"list_id": "1234",
"value": "10.0.0.2",
"created_at": "2024-01-15T10:00:00.000Z"
}
}
}
}

Human Readable Output#

Kibana Value List Item#

Value list item IDList IDValueCreation date
5678123410.0.0.22024-01-15T10:00:00.000Z

es-kibana-value-list-item-delete#


Deletes a value list item.

Base Command#

es-kibana-value-list-item-delete

Input#

Argument NameDescriptionRequired
space_idRefer to https://www.elastic.co/docs/deploy-manage/manage-spaces for more information.Optional
value_list_item_idValue list item's identifier. Required if list_id and value are not specified.Optional
value_list_idValue list's identifier.Optional
valueThe value used to evaluate exceptions. Required if id is not specified.Optional
refreshDetermines when changes made by the request are made visible to search.Optional

Context Output#

There is no context output for this command.

Command Example#

!es-kibana-value-list-item-delete value_list_item_id="5678"

Context Example#

{}

Human Readable Output#

The value list item 5678 has been successfully deleted.

es-kibana-value-list-item-export#


Exports all items of a value list as a file (returned to the War Room).

Base Command#

es-kibana-value-list-item-export

Input#

Argument NameDescriptionRequired
space_idRefer to https://www.elastic.co/docs/deploy-manage/manage-spaces for more information.Optional
value_list_idValue list's ID to export.Optional

Context Output#

There is no context output for this command.

Command Example#

!es-kibana-value-list-item-export value_list_id="1234"

Context Example#

{}

Human Readable Output#

The value list 1234 has been exported successfully.

es-kibana-value-list-item-import#


Import value list items from a TXT or CSV file.

Base Command#

es-kibana-value-list-item-import

Input#

Argument NameDescriptionRequired
space_idRefer to https://www.elastic.co/docs/deploy-manage/manage-spaces for more information.Optional
value_list_idList's ID to import.Optional
typeType of the importing list.Optional
refreshDetermines when changes made by the request are made visible to search.Optional
entry_idEntry ID for the file containing the items to import.Required

Context Output#

PathTypeDescription
Elasticsearch.Kibana.ValueListItem.idStringThe value list item ID.
Elasticsearch.Kibana.ValueListItem.list_idStringThe value list ID.
Elasticsearch.Kibana.ValueListItem.nameStringThe value list item name.
Elasticsearch.Kibana.ValueListItem.descriptionStringThe value list item description.
Elasticsearch.Kibana.ValueListItem.created_atDateThe creation date of the value list item.

Command Example#

!es-kibana-value-list-item-import value_list_id="1234" entry_id="1@1"

Context Example#

{
"Elasticsearch": {
"Kibana": {
"ValueListItem": {
"id": "5678",
"list_id": "1234",
"value": "10.0.0.1",
"created_at": "2024-01-15T10:00:00.000Z"
}
}
}
}

Human Readable Output#

Kibana Value List Item#

Value list item IDList IDValueCreation date
5678123410.0.0.12024-01-15T10:00:00.000Z